Error while loading shared libraries: on Ubuntu

The latest version 1.18.2 may give this error when running on Ubuntu LTS 20.04.3.

There is a missing library dependency in the package.

so below should fix this error:

apt-get install libopenexr24:amd64

robomotion@onegig:~$ robomotion-deskbot --version
robomotion-deskbot: error while loading shared libraries: cannot open shared object file: No such file or directory
robomotion@onegig:~$ logout
root@onegig:~# apt-get install libopenexr24:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 9 not upgraded.
Need to get 0 B/592 kB of archives.
After this operation, 3205 kB of additional disk space will be used.
Selecting previously unselected package libopenexr24:amd64.
(Reading database ... 79526 files and directories currently installed.)
Preparing to unpack .../libopenexr24_2.3.0-6ubuntu0.5_amd64.deb ...
Unpacking libopenexr24:amd64 (2.3.0-6ubuntu0.5) ...
Setting up libopenexr24:amd64 (2.3.0-6ubuntu0.5) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
root@onegig:~# su - robomotion
robomotion@onegig:~$ robomotion-deskbot --version
robomotion-deskbot version 1.18.2

Hi, I’m using Ubuntu 18.04 LTS 64bit on a VPS and that version doesn’t seem to exist in the repo yet, so I tried the “just install anything that starts with libopenexr*” approach.

After installing so much it looked like it took its dependencies lesson from Windows installers, it didn’t change the error that still appears: “error while loading shared libraries: cannot open shared object file: No such file or directory” (and “error while loading shared libraries:” too)


Currently only Ubuntu 20.04 is supported.

We are working on an .AppImage version of the robot that will run on any distribution.

You can follow the progress from our Roadmap Board

or if possible you can setup a Ubuntu 20.04 box and try to install the robot there. Here is how to setup on Ubuntu VPS

i get the same error with Ubuntu 22.04. Guess I have also to wait for the appImage?

Yes, it is a work in progress currently.

@Rohat is working on this.

1 Like

For Ubuntu 22, we have created a new package for the latest release and you follow these steps to install:

dpkg -i robomotion_1.18.9-rc.3_ubuntu22_amd64.deb
apt-get install -f -y
apt-get install -y libopenexr25 libopenjp2-7 libtbb12

Just an update here.

We now provide downloads for both Ubuntu 20 and Ubuntu 22 on our downloads page, and

$ wget
$ dpkg -i robomotion_1.18.11_amd64.deb
$ apt-get install -f -y

is enough to install on a Linux Terminal.