Robomotion Desktop Connect issue

Hi Team,

After downloading the robomotion connect (for mac) I am not able to connect to the server.

Pleaes assist.

Regards,
Swapnil

Hello @swapnilsingh

Please make sure your workspace, username and password is correct. Can you login from www.robomotion.io to your workspace?

You can find our connection related documentation here:

Also if you are behind a firewall, make sure wss://proxy.robomotion.io is allowed.

Hi Faik,

Thanks for the quick response. I have triple checked all the credentials.

please let me konw if any additional permissions are required for MAC.

Can you login to your workspace from browser ? If not you can try Forgot Password.

Yes I am able to login from browser.

Hi, @swapnilsingh,
What kind of error do you encounter when you try to connect? Can you share a screenshot?

Hi,

It says connecting and does not show anything else.

if your workspace address is

https://xyz.robomotion.io

please make sure you enter

Workspace: xyz.robomotion.io
User: your@email.com
Pass: your workspace password

If all above is correct, please try from another network to test if this is a firewall related rule blocking you to connect to websocket addres.

Hi @faik,

I am using the exact same configuration what you have mentioned but it is still not working for me. I am not using any sort of proxy.

Hi, @swapnilsingh,
Additionally, you can use terminal for connecting your robot.

Assume that your workspace address is
https://xyz.robomotion.io
and your e-mail address is
your@email.com

So you should write the following command on terminal

robomotion-deskbot connect -i your@email.com -w xyz.robomotion.io

Then it will prompt you to enter your password.
Write your password, then press enter
If everything is okay, your robots will be listed (your default robot will be showd)
Select it by pressing enter. Now, your robot should be connected

Hi @latifuluman,

I guess for this I need to install some binary? Where can I download the binaries from ?

@swapnilsingh you don’t need extra binary, installing robomotion (currently latest version is 1.4.0) is enough. Did you try and encounter with an error like installing additional binary?

For console

$ cd /Applications/Robomotion.app/Contents/MacOS/
$ ./robomotion-deskbot connect -i your@email.com -w yourworkspace.robomotion.io

For the tray app you can also try restarting your Mac and trying to connect from the tray with the right credentials.

Hi @faik,

It’s still not working.

Referenced from: /Applications/Robomotion.app/Contents/Frameworks/libopencv_core.4.3.dylib
Reason: image not found
Abort trap: 6

Ok if you are using the latest version this seems to be the problem, thanks for reporting. We will look into this and update the package.

@swapnilsingh you can also come to https://slack.robomotion.io for faster communication.

Problem fixed in 1.4.2 Mac installer. Thanks for the report.

You can download latest version from here:
https://storage.googleapis.com/robomotion/downloads/Robomotion-1.4.2.dmg

Hi @faik,

Still the same issue. :frowning:

Can you provide the console output again.

And also

./robomotion-deskbot —version

output please.

Thanks