About the Get Help category

Ask questions to get help for your Automation Ideas, Setup, Flows or JavaScript code.

Hi to everyone, i’m trying to connect my workspace after dowloading and installing my robot but I’m having always the same problem as you can see from the screenshot: ERROR Connection failed: API connection error
someone has got an idea where the problem should be?

1 Like

Hello @ummeister,

Please try remark.robomotion.io for your Workspace without https:// at the beginning and / at the end.

I have the same thing happening with me. I have taken off the https:// at the start and the / at the end but still doesn’t look like it is wanting to connect. How did you go with your connection?


Can you ping this address, like

ping practical.robomotion.io
PING practical.robomotion.io ( 56(84) bytes of data.

Hi there,
I’ve got the exact same issue.
I tried adpgroup.robomotion.io with no success.
But pinging the URL does respond :

Can I see somewhere in the logs what request may be blocked ?


You can also try starting from the console with,

robomotion-deskbot connect -i your_email -w your_workspace.robomotion.io

Can you try with the latest version ( currently 1.18.0 ) from Downloads - Robomotion RPA.

Where we see this error is most of the time a wrong workspace like only writing your_workspace instead of your_workspace.robomotion.io or leaving some spaces somewhere. Or sometimes we see a TLS handshake timeout error which we increased in the last release.