Element not found

I recorded a short Loom video to make it easier to see:

Also, I tried the “Wait Element” command as well. It is for some reason not seeing it as an element or a text field.

When I searched “click” “textarea” “javascript” i found some results. Maybe you can try these with Browser → Run Script node. I tried to signup and try but it requires payment.


also for Element not found , I would suggest using “Wait Element” node before interacting with the element. use the same xpath for the text area in a Wait Element node. And after that try Click Element or Run Script.

I created a test flow for you, that sets data to the textarea, clicks textarea, and gets data from the textarea.

Maybe this example may help


It doesn’t make sense, the Run Script node. There seems to be no space for a run script java whatever you said. This isn’t very user-friendly and the tutorials are not helpful at all. They just say what things are but not how to use them. I can give you a login if that helps. But this makes no sense to me at all.

Sorry, but this is not a no-code tool. Near all RPA products are low-code tools, even the ones that market themselves as no-code require some kind of scripting. Our native scripting language is Javascript and you need some basic knowledge of JS.

Here is a course we recommend for beginners if you are interested: JavaScript Tutorial: Learn JavaScript For Free | Codecademy

We also have a dedicated channel [ #javascript ] in our community server, just to help beginners in our Discord server at https://community.robomotion.io where you can ask us anything related to JS if you need to.